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Thank you for choosing our product, we wish you lot of fun using it.  
 

What is ESX ? 
 

The ESX, also known as « Electribe SX » is a hardware audio workstation designed by Korg. It is a sampler with 
Stretch/Slice, Keyboard and drum parts, and it can record patterns and songs. Go to « Korg » web site for more 
information. 
 

What is DirectESX for? 
 

DirectESX is a VSTi/AU MIDI plug-in that allows you to control in real-time every sound shaping parameters of the Korg 
ESX in your DAW. 
 

As a benefit of the host integration, DirectESX provides an incredible feature set including total recall and parameters  
automation, combined with the power, stability and punchy sound of the ESX. 
 

You must own the Korg ESX to use DirectESX. 
 

DirectESX Features 
 

-  Full parameters control and automation from a VST host software 
 (2 Keyboard parts, 2 Stretch parts, 1 slice part, 1 Audio in part, and 9 drum parts) 
-  A clean and helpful interface specially designed for the ESX 
-  Total recall : The whole state of the ESX is saved in the DAW project and can be loaded back. 
-  System-Exclusive dumps : Get all the patterns of your ESX in the DirectESX interface, then modify and 
 reverse-engineer existing patches easily. 

 



Installation & Requirements 

3 

Installation 
 

To install DirectESX on your system, simply copy the DirectESX plugin file in your plugins directory: 
- Windows:  Copy « DirectESX.dll », the default path is « C:\Program Files\VSTPlugins » 
- Mac VST : Copy « DirectESX.vst » to /Library/Audio/Plug-Ins/VST 
- Mac Audio Unit : Copy « DirectESX.component » to /Library/Audio/Plug-Ins/Components 

 

Requirements 
 

PC minimum requirements: 
 
    - Pentium III 800 Mhz  
    - 512 MB RAM  
    - Windows XP/Vista/7  
    - MIDI interface  
    - VST 2.4 compliant host  
 
MAC:  
 
    - OS X 10.5 or 10.6 
    - Intel Core Duo 
    - 1 GB RAM 
    - MIDI interface  
    - VST 2.4 compliant host  

 
 



MIDI Mode 
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DirectESX features 2 midi modes: Host and DirectMidi 
 

Host mode: 
 
In host mode the MIDI messages are going through the host software (ie Cubase, Live…).  
Advantage:  The MIDI device is shared between the host and DirectESX. 
Disavantages:  It requires to setup host tracks correctly ; All the MIDI messages may not not be transmitted (host filtering), 
making it incompatible with DirectESX on some cases. Sysex are not supported. 
 

DirectMidi mode: 
 
In DirectMidi mode the MIDI messages are directly exchanged between DirectESX and the MIDI device (ie sound card). 
Advantage: No setup is needed in the host software, all MIDI messages are exchanged including sysex, giving expanded 
possibilities (Pattern name, full dumps…), and this is independant of the host. 
Disavantages:  The MIDI device is dedicated to DirectESX, but notes and midi messages that are not used by the ESX are 
forwarded to the host. Some MIDI interfaces may not be compatible as they don’t manage sysex correctly, however DirectESX 
will try to repair corrupted Sysex messages to enhance compatibility. 
 
 

 
 



Setup tab 
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Knob mode determines the way you 

use the mouse to control the knobs. 

In DirectMIDI mode you have to 

select the MIDI device where your 

ESX is connected. 

Indicates whether the 

device could be opened 

This indicates if an ESX hardware has 

been detected (DirectMIDI only) 

Dumps of the current pattern or 

Banks (DirectMIDI only) Midi interface test 



Midi interface test 
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• The midi interface test can determine if your midi interface is compatible with DirectESX. 
• To run this test you will need to connect the MIDI IN of your interface directly to the MIDI OUT 
• The test takes a few seconds. Once completed it will display a report of the test result. 

Midi Interface 

MIDI IN MIDI OUT 

Electribe SX 

MIDI IN MIDI OUT 

Midi Interface 

MIDI IN MIDI OUT 

Midi configuration to use the ESX Midi configuration to run the test 



Host compatibility 
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DirectMIDI mode: 
 
In DirectMIDI mode, the transmission of MIDI messages is not dependant of the Host. The only compability issue may come 
from the MIDI device used. 
 

Host mode: 
 

Host\Feature Integration Controller Dumps 

Cubase SX v3~6 

FL Studio v8 v9 Needs manual 
mapping 

Sonar v8 

Live v8 

Acid pro v7 

-  Integration : DirectESX is fully functional to control, automate and recall all the parameters of the ESX. 
 
-  Controller : The Korg ESX can be used as a midi controller and DirectESX interface is automatically updated when 
 a parameter value changes. Also ESX internal motion sequences can be seen on DirectESX interface.  
 
-  Dumps : It is possible to dump pattern banks (or just current pattern) from the ESX by receiving MIDI Sys-Ex 
 message in DirectESX. 

DirectESX mostly rely on MIDI message. You may 
encounter some compatibility issues with some hosts 
that does not manage MIDI messages properly. 
 
Here is our non-exhaustive compatibility chart, you 
may get the last updated version at 
www.directsynth.com (support section). 
 

 

http://www.directsynth.com/


ESX Configuration 
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As DirectESX relies on MIDI communication, your ESX must be properly connected and configured: 
 

• Use a MIDI cable to connect the MIDI OUT connector of your sound card to the ESX’s MIDI IN connector. 
• Use a MIDI cable to connect the MIDI IN connector of your sound card to the ESX’s MIDI OUT connector. 

 
Make sure the MIDI configuration of your ESX is set to the factory settings: (Refer to the MIDI mode section of your ESX manual) 

Keyboard Parameter CC 

Glide CC#5 

Filter type CC#83 

Filter cutoff CC#74 

Filter resonance CC#71 

Filter Eg int CC#79 

Level CC#7 

Pan CC#10 

Eg Time CC#75 

Amp Eg CC#86 

Start Point CC#18 

Reverse CC#19 

Keyboard Parameter CC 

Roll CC#85 

Fx send CC#91 

Fx select CC#81 

Mod type CC#87 

Mod depth CC#90 

Mod speed CC#89 

Mod dest CC#88 

Mod bpm sync CC#82 

Motion seq sw CC#80 

Global Parameter CC 

FX Chain CC#23 

FX1 Parameter CC 

FX Type CC#12 

FX Edit1 CC#92 

FX Edit2 CC#93 

FX Motion Seq sw CC#20 

FX2 Parameter CC 

FX Type CC#13 

FX Edit1 CC#94 

FX Edit2 CC#95 

FX Motion Seq sw CC#21 

FX3 Parameter CC 

FX Type CC#24 

FX Edit1 CC#25 

FX Edit2 CC#26 

FX Motion Seq sw CC#22 

Parts Channels 

Keyboard1 1 

Kayboard2 2 

Stretch 10 

Slice 10 

Audio In 10 

Drums 10 

MIDI Filter Value 

PCEN oooo 



DirectESX Interface 
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How to use in hosts: general rules 
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DirectMIDI mode: 
 
•This mode is enabled as default in DirectESX 
•Make sure the MIDI device where you have connected your ESX is not used by the host software. You will have to disable it 
from a setting menu. 
•To send notes from the host to the ESX, create a midi track and select input/output to DirectESX plugin. Then use 1 and 2 
channels for Keyboard parts, and 10 for the others (Stretch, Slice, Audio in, Drums). 
•For automation, it works the same way than in host mode, you may refer to host mode configuration pages. 
 

Host mode: 
 
•As the default mode is DirectMIDI you will have to select « Host » In DirectESX. 
•Make sure the MIDI device where you have connected your ESX is enabled the host software. 
•To send notes from the host to the ESX, create a midi track and select output to the MIDI interface where your ESX is 
connected. Then use 1 and 2 channels for Keyboard parts, and 10 for the others (Stretch, Slice, Audio in, Drums). 
•This mode is not available for the Audio Unit version. 
 
 

 
 



How to use with Cubase 
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1. Add « DirectESX » VST by using the « Devices->VST Instruments » menu (or F11 key).  
 
 
 
 

2. In DirectESX select the MIDI interface where your ESX is connected. 
If the devices could be opened and that the ESX hardware had been detected then you should be able to 
control the ESX from DirectESX and vice versa. 
 
 
 
 

3. To send notes to the ESX, create a MIDI track, then send Input and output to « DirectESX ». Then use 1 
and 2 channels for keyboard parts, and 10 for others. 
 
 
 
 
 

4. For automation expand the « VST Intruments » and « DirectESX » tracks and select 
one or more parameters to automate. 
 

DIRECT MIDI MODE 



How to use with Cubase (1/2) 
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1. Add « DirectESX » VST by using the « Devices->VST Instruments » menu (or F11 key). In DirecESX click on 
« Host » to change midi mode  
 
 
 
 

2. Add a MIDI Track and set « IN » to « DirectESX », and « OUT » to your midi interface where the ESX is 
connected (« Multiface Midi » in our case). Also set « Channel » to « ANY ». 
 
 
 
This midi track will send midi from DirectESX to the ESX. We have renamed this midi track to « ESX 
Send ». 
 

3. You should now be able to control the ESX from DirectESX. Confirm the « Sync now? » question from 
DirectESX interface. This will transmit the current pattern to the ESX. 
 
 
 
On your ESX select the first drum part. Now change the filter type of the drum part from DirectESX. You 
should see that it is also changing on the ESX. If not, check your midi interface and cables. Also the midi 
track has to be selected with the record button enabled (red). 

HOST MODE 



How to use with Cubase (2/2) 
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4. Now we are going to enable the control of DirectESX from the ESX. 
Add another MIDI track. Set « In » to the MIDI interface where the ESX is connected (« Multiface Midi » in 
our case). Set « Out » to « DirectESX ». Set « Channel » to « ANY ». Rename this track to « ESX Receive » 
 
 
 

5. Now enable the record buttons for both midi tracks. 
 
 
IMPORTANT : Always make sure these 2 buttons are enabled, else the midi sync with the ESX will not 
work. 
 
Turn a knob on the ESX, it moves in the DirectESX interface! (make sure you are working on the same part 
between the ESX and DirectESX, else you won’t see the visual feedback). 
 
Now you should normally be able to control the ESX from DirectESX and vice-versa. 
 

6. For automation expand the « VST Intruments » and « DirectESX » tracks and select 
one or more parameters to automate. 

HOST MODE 



How to use with Live (1/2) 
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1. In « Options->Preferences->MIDI » make sure your midi interface is set to « OFF » for tracks Input/Output. 
In our case, the midi interface where the ESX is connected is « Multiface Midi » 
 
 
 
 
 

2. Create a midi track and rename it to « DirectESX », 
then set « Midi from » to « No input » 
 

3. In the left browser select the Plug-in tab and drag&drop DirectESX 
to the MIDI track. 
 
 

4. In DirectESX select the MIDI interface where your ESX is connected. 
If the devices could be opened and that the ESX hardware had been detected then you should be able to 
control the ESX from DirectESX and vice versa. 
 
 
 
 

DIRECT MIDI MODE 



How to use with Live (2/2) 
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5. To send notes to the ESX, create another MIDI track, rename it to « Keyboard1 » 
Set « MIDI from » and « MIDI To » to DirectESX. 
Select Track-In to « 1-DirectESX » (Note: select 1~2 for keyboard parts, 10 for all others) 
 

6. Set Monitor to « Auto » when you want to send notes from Live sequencer 
Set Monitor to « In » when you want to send notes from a MIDI keyboard 
 
 

7. For parameters automation, first move the desired parameter in DirectESX interface, 
then it will appear in the parameters list. 

DIRECT MIDI MODE 



How to use with Live (1/2) 
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1. In « Options->Preferences->MIDI » make sure your midi interface is set to « ON » for tracks Input/Output. 
In our case, the midi interface where the ESX is connected is « Multiface Midi » 
 
 
 
 
 

2. Create 2 midi tracks. Rename the first one to « DirectESX » and the other 
one to « ESX Send ». 
 
 

3. In the left browser select the Plug-in tab and drag&drop DirectESX 
to the first MIDI track. In DirecESX click on « Host » to change midi mode 
 

4. In the DirectESX track, set « Midi from » to « No input » 
In The ESX Send track, set « Midi from » to « DirectESX », 
Monitor « IN » and « MIDI to » to your midi interface (multiface in our case). 
 
You should now be able to control the ESX from DirectESX. Note that on Live 
the channel is set in the midi track, not in DirectESX. To control Stretch, 
Slice, audio in and drum parts, select channel 10. 
 
You can try to change the Keyboard 1 part filter type from DirectESX, it should change on the ESX. 
(Select channel 1 in Live and select the keyboard 1 part in the ESX). 
 

HOST MODE 



How to use with Live (2/2) 
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5. If you want to control DirectESX from the ESX, add a third MIDI track, rename it « ESX Receive » 
Set « MIDI from » to your midi interface (Multiface midi in our case), 
Set Monitor to « IN » and « MIDI To » to DirectESX. 
 
Turn the Cutoff knob of the Keyboard 1 part from the ESX, it should move 
in the DirectESX interface. 
 
 
Note: In the ESX Receive track, change the « Track In » parameter to select the channel you want to use. 
 
 

6. For parameters automation, first move the desired parameter in DirectESX interface, 
then it will appear in the parameters list. 

Known bugs due to Live wrong MIDI NRPN management: 
   - When sending Mutes from the ESX, sometimes a part mute will not have the right value on DirectESX. 
   - If a « Drum sample » send by the ESX is not received by DirectESX, try sending the « Drum 6A sample » 
then the « Drum1 sample ». Then it should work. 

HOST MODE 



How to use with FL Studio (1/2) 
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1. Add « DirectESX » VST by using the « Channels->Add one » menu. 
If « DirectESX » is not in the list, use the « More… » item to add new VST 
instruments. (refer to your FL Studio manual). 
In DirecESX click on « Host » to change midi mode  
 
 
 
 

2. In Options->MIDI settings, associate a port number to the midi interface where the ESX is connected. 
« Multiface Midi » in our case, and we have selected port « 0 ». 
 
 
 
 
 

3. In DirectESX left menu, select « Show MIDI output port », then on the right select port « 0 » 
 
 
 
 
 
 
Now DirectESX  should be able to control the ESX. Change the filter type of the first keyboard part in 
DirectESX, it should also change on the ESX (make sure the first keyboard part is also selected on the ESX). 
 

HOST MODE 



How to use with FL Studio (2/2) 
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4. You can also use the ESX to control DirectESX but this has to be configured manually. This is due to FL 
Studio midi parameters management. 
For example: 
  
• Move the Keyboard 1 part Cutoff knob on DirectESX 
• On DirectESX left menu, select « Last tweaked parameter » 

then « Link to controller ». 
• Now turn the cutoff know on your ESX 
• You should see it moving on the DirectESX interface. 
 

5. For parameter automation use DirectESX left menu, then 
select « Browse parameters ». All the parameters will show up 
on the left list. 
 
 
 
 
 

6. If you want to send notes to each part, we suggest not to use the « Midi out » plugin provided with fl 
studio because it will send level and pan midi messages. Instead you can find on the web free vst 
« midi out» plugins for that. 
 
 

HOST MODE 



How to use with Reaper (1/2) 
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1. In Options->Preferences, then in MIDI Devices, check that the device connected to the ESX 
("multiface" in my case) is "Enabled+Control" (for midi in) and "Enabled" (for midi out).  
 

2. Track->Insert virtual Instrument on new track. Then select DirectESX. In DirecESX click on 
« Host » to change midi mode 
 

HOST MODE 



How to use with Reaper (2/2) 
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3. In the new track click on the small "io" button, then select your midi device in "Hardware output"  
 

4. Select Keyboard1 part on both the ESX and DirectESX, if you turn a knob on the ESX you should see it moving in 
DirectESX. Then in DirectESX change the filter type, you should see the led changing on the ESX 

HOST MODE 



How to use with Sonar 
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1. Create a new blank project 
 

2. In Options->Global->VST Plug-ins, make sure that a folder 
points to a location where you have copied DirectESX.dll 
 

3. Insert->Soft Synths->DirectESX ; make sure that "Simple 
instrument track" and "Enable MIDI output" are checked. 
In DirecESX click on « Host » to change midi mode 
 

4. On the created track, set the INPUT to the midi interface that is 
connected to the ESX, select omni channel. From this point you 
should be able to control DirectESX from the ESX. For example, 
move the cutoff knob of Keyboard1, you should see it moving 
on DirectESX. 
 

5. Insert->MIDI track ; Set INPUT to "DirectESX 1 - Omni" ; Set 
OUTPUT to the midi interface where is connected the ESX. You 
should now be able to control the ESX from DirectESX. For 
example, change the filter type of Keyboard1 in DirectESX, you 
should see the led changing on the ESX. 
 

6. Make sure you have enabled the « Input echo » button on both 
tracks 
 

HOST MODE 



How to use with Logic 
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1. Add « DirectESX » Audio unit by adding a software instrument track. Then Click on I/O and select 
« AU MIDI-controlled effects -> DirectSynth -> DirectESX » 
 
 
 
 
 

2. In DirectESX select the MIDI interface where your ESX is connected. 
If the devices could be opened and that the ESX hardware had been detected then you should be 
able to control the ESX from DirectESX and vice versa. 
 
 
 
 
 

3. To send notes to each part of the ESX, create another instrument track (In this example we’ll send to 
Keyboard 2), then go to Logic menu « Windows->Environment » 
 

4. Click on the upper arrow of the new track (here « Keyboard 2 ») and link to the DirectESX track. Then 
set the midi channel, here we set 2 for keyboard 2. (1 and 2 for keyboard, 10 for others) 
 
 
 
 
 

Audio Unit / DIRECT MIDI 
MODE 



MIDI Dumps (1/2) 
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MIDI Dump is a feature that makes it possible to get the whole ESX content in DirectESX. 
The 256 patterns can be dumped by banks of 64 (A, B, C, D). 
 
Once dumped, the content of the patterns are available in DirectESX. This enables the user to analyze or 
modify them easily. Also the patterns can be saved and retransmitted to the ESX. 
 
This feature is not available on every host software. You can refer to the host compatibility chart for more 
information. 
 
1. Open your host software and configure a track so that MIDI is sent to DirectESX 
2. On the ESX, press the MIDI Key (the key will light) 
3. Hold down the shift key and press step key 12 (MIDI utility) 
4. The value display will indicate « Filter ». Turn the dial to change this to « Dump », and press key 12 
5. Turn the dial to select the data you want to transmit (PtBnkA, PtBnkB, PtBnkC or PtBnkD) 
6. Press key 12 once again to transmit the data. 
7. Wait about 2 minutes, then you should see the « Accept pattern bank » question on DirectESX 

 
 
 
 

8. Once accepted you will have access to the patterns from the patch list of the plugin. 

HOST MODE 



MIDI Dumps (2/2) 
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To use the Dumps in Cubase check the following: 
 
- Go in Preferences -> MIDI -> MIDI Filter 
- Make sure that « Sysex » is unchecked. 

HOST MODE 
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- For any news or updates : www.directsynth.com 
 

- For any questions or support : support@directsynth.com 

http://www.directsynth.com/
mailto:support@directsynth.com

